Vulnerability · Published Sep 10, 2024 · Assigned by GitHub_M
CVE-2024-45590body-parser vulnerable to denial of service when url encoding is enabled
High 7.5
In plain English
A high-severity security flaw in body-parser from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
body-parser is Node.js body parsing middleware. body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service. This issue is patched in 1.20.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-body-parser | no fix listed | DEBIAN-CVE-2024-45590 |
| Debian:13 | node-body-parser | 1.20.3+~1.19.5-1 | DEBIAN-CVE-2024-45590 |
| Debian:14 | node-body-parser | 1.20.3+~1.19.5-1 | DEBIAN-CVE-2024-45590 |
| Ubuntu:22.04:LTS | node-body-parser | no fix listed | UBUNTU-CVE-2024-45590 |
| Ubuntu:24.04:LTS | node-body-parser | no fix listed | UBUNTU-CVE-2024-45590 |
| npm | body-parser | 1.20.3 | GHSA-qwcr-r2fm-qrc7 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| expressjs | body-parser | < 1.20.3 |
Weakness: CWE-405 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H