Vulnerability · Published Nov 18, 2024 · Assigned by apache
CVE-2024-45505Apache HertzBeat: Exists Native Deser RCE and file writing vulnerabilities
High 8.8
In plain English
A high-severity command injection in Apache HertzBeat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 83% of all known vulnerabilities).
Severity (CVSS 3.1)8.8High
Exploit odds (30 days)2.2%top 17.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache HertzBeat (incubating). This vulnerability can only be exploited by authorized attackers. This issue affects Apache HertzBeat (incubating): before 1.6.1. Users are recommended to upgrade to version 1.6.1, which fixes the issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache HertzBeat | 0 – before 1.6.1 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H