Vulnerability · Published Sep 5, 2024 · Assigned by GitHub_M
CVE-2024-45401stripe-cli Path Traversal vulnerability
High 7.6
In plain English
A high-severity path traversal in stripe-cli from stripe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/stripe/stripe-cli | 1.21.3 | GHSA-fv4g-gwpj-74gr |
| Go | github.com/stripe/stripe-cli | 1.21.3 | GO-2024-3119 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| stripe | stripe-cli | >= 1.11.1, < 1.21.3 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/stripe/stripe-cli/security/advisories/GHSA-fv4g-gwpj-74gr x_refsource_CONFIRM