Vulnerability · Published Sep 2, 2024 · Assigned by GitHub_M
CVE-2024-45312Arbitrary language parameter can passed to `aspell` executable via spelling requests in overleaf
Medium 5.3
In plain English
A medium-severity path traversal in overleaf from overleaf. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities).
Official description
Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server. This causes `aspell` to attempt to load a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7. Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature. However, upgrading is advised.
Affected products (as reported)
Weakness: CWE-641, CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/overleaf/overleaf/security/advisories/GHSA-pxm4-p454-vppg x_refsource_CONFIRM
- https://github.com/overleaf/overleaf/commit/b5e5d39c3ad4e7763d42b837738955f8ded4dcd3 x_refsource_MISC
- https://github.com/overleaf/toolkit x_refsource_MISC