Vulnerability · Published Aug 28, 2024 · Assigned by mitre
CVE-2024-45233
High 7.3
In plain English
A high-severity improper access control in the in2code/powermail package (Packagist). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | in2code/powermail | 7.5.0 | GHSA-9jqr-5x45-pgw8 |
| Packagist | in2code/powermail | 8.5.0 | GHSA-9jqr-5x45-pgw8 |
| Packagist | in2code/powermail | 10.9.0 | GHSA-9jqr-5x45-pgw8 |
| Packagist | in2code/powermail | 12.4.0 | GHSA-9jqr-5x45-pgw8 |
Affected products (as reported)
Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L