Vulnerability · Published Oct 16, 2024 · Assigned by apache
CVE-2024-45217Apache Solr: ConfigSets created during a backup restore command are trusted implicitly
High 8.1
In plain English
A high-severity security flaw in Apache Solr from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Insecure Default Initialization of Resource vulnerability in Apache Solr. New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata. ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request. "trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized. This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization. Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.solr:solr | 8.11.4 | GHSA-h7w9-c5vx-x7j3 |
| Maven | org.apache.solr:solr | 9.7.0 | GHSA-h7w9-c5vx-x7j3 |
| Ubuntu:22.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2024-45217 |
| Ubuntu:24.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2024-45217 |
| Ubuntu:25.10 | lucene-solr | no fix listed | UBUNTU-CVE-2024-45217 |
| Ubuntu:26.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2024-45217 |
| Ubuntu:26.10 | lucene-solr | no fix listed | UBUNTU-CVE-2024-45217 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Solr | 6.6.0 – before 8.11.49.0.0 – before 9.7.0 |
Weakness: CWE-1188 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N