Actively exploited · Published Nov 19, 2024 · Assigned by apple

CVE-2024-44308

High 8.8 Exploited

In plain English

A high-severity security flaw in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on November 21, 2024). The chance it is exploited in the next 30 days is estimated at 9.9% (higher than 96% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)9.9%top 4.4% of all CVEs
Exploited in the wildYesCISA KEV since Nov 21, 2024
Attack tooling1Public PoC

CISA guidance

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Dec 12, 2024.

Official description

The issue was addressed with improved checks. This issue is fixed in Safari 18.1.1, iOS 17.7.2 and iPadOS 17.7.2, iOS 18.1.1 and iPadOS 18.1.1, macOS Sequoia 15.1.1, visionOS 2.1.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited on Intel-based Mac systems.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12webkit2gtk2.46.4-1~deb12u1DSA-5823-1
Debian:12webkit2gtk2.46.4-1~deb12u1DEBIAN-CVE-2024-44308
Debian:13webkit2gtk2.46.4-1DEBIAN-CVE-2024-44308
Debian:14webkit2gtk2.46.4-1DEBIAN-CVE-2024-44308
Debian:12wpewebkitno fix listedDEBIAN-CVE-2024-44308
Debian:13wpewebkit2.46.4-1DEBIAN-CVE-2024-44308
Debian:14wpewebkit2.46.4-1DEBIAN-CVE-2024-44308
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-44308
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-44308
Ubuntu:22.04:LTSwebkit2gtk2.46.4-0ubuntu0.22.04.1USN-7142-1
Ubuntu:22.04:LTSwebkit2gtk2.46.4-0ubuntu0.22.04.1UBUNTU-CVE-2024-44308
Ubuntu:24.04:LTSwebkit2gtk2.46.4-0ubuntu0.24.04.1USN-7142-1
Ubuntu:24.04:LTSwebkit2gtk2.46.4-0ubuntu0.24.04.1UBUNTU-CVE-2024-44308
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2024-44308

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 18.1.1
Apple iOS and iPadOS 0 – before 17.7.20 – before 18.1.1
Apple macOS 0 – before 15.1.1
Apple visionOS 0 – before 2.1.1

References