Vulnerability · Published Apr 30, 2024 · Assigned by VulDB
CVE-2024-4327Apryse WebViewer PDF Document cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in WebViewer from Apryse. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities).
Official description
A vulnerability was found in Apryse WebViewer up to 10.8.0. It has been classified as problematic. This affects an unknown part of the component PDF Document Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 10.9 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-262419. NOTE: The vendor was contacted early about this disclosure and explains that the documentation recommends a strict Content Security Policy and the issue was fixed in release 10.9.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- VDB-262419 | Apryse WebViewer PDF Document cross site scripting vdb-entry, mitigation
- VDB-262419 | CTI Indicators (IOB, IOC, TTP) signature, permissions-required
- Submit #321231 | apryse WebViewe 10.8.0 Cross Site Scripting third-party-advisory
- https://1drv.ms/b/s!AqJ7dHWS4CD_l0acw2hDjgo-C2zC?e=DOGPmq exploit
- https://docs.apryse.com/documentation/web/faq/content-security-policy/#recommended-policy mitigation