Vulnerability · Published Sep 5, 2024 · Assigned by GitHub_M
CVE-2024-42491A malformed Contact or Record-Route URI in an incoming SIP request can cause Asterisk to crash when res_resolver_unbound is used
Medium 5.7
In plain English
A medium-severity null pointer dereference in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Asterisk is an open-source private branch exchange (PBX). Prior to versions 18.24.3, 20.9.3, and 21.4.3 of Asterisk and versions 18.9-cert12 and 20.7-cert2 of certified-asterisk, if Asterisk attempts to send a SIP request to a URI whose host portion starts with `.1` or `[.1]`, and res_resolver_unbound is loaded, Asterisk will crash with a SEGV. To receive a patch, users should upgrade to one of the following versions: 18.24.3, 20.9.3, 21.4.3, certified-18.9-cert12, certified-20.7-cert2. Two workarounds are available. Disable res_resolver_unbound by setting `noload = res_resolver_unbound.so` in modules.conf, or set `rewrite_contact = yes` on all PJSIP endpoints. NOTE: This may not be appropriate for all Asterisk configurations.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | asterisk | 20.9.3-r0 | ALPINE-CVE-2024-42491 |
| Alpine:v3.21 | asterisk | 20.9.3-r0 | ALPINE-CVE-2024-42491 |
| Alpine:v3.22 | asterisk | 20.9.3-r0 | ALPINE-CVE-2024-42491 |
| Alpine:v3.23 | asterisk | 20.9.3-r0 | ALPINE-CVE-2024-42491 |
| Alpine:v3.24 | asterisk | 20.9.3-r0 | ALPINE-CVE-2024-42491 |
| Debian:14 | asterisk | 1:20.9.3~dfsg+~cs6.14.60671435-1 | DEBIAN-CVE-2024-42491 |
| Ubuntu:22.04:LTS | asterisk | no fix listed | UBUNTU-CVE-2024-42491 |
| Ubuntu:24.04:LTS | asterisk | no fix listed | UBUNTU-CVE-2024-42491 |
| Ubuntu:25.10 | asterisk | no fix listed | UBUNTU-CVE-2024-42491 |
| Ubuntu:26.04:LTS | asterisk | no fix listed | UBUNTU-CVE-2024-42491 |
| Ubuntu:26.10 | asterisk | no fix listed | UBUNTU-CVE-2024-42491 |
Affected products (as reported)
Weakness: CWE-252, CWE-476 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
References
- https://github.com/asterisk/asterisk/security/advisories/GHSA-v428-g3cw-7hv9 x_refsource_CONFIRM
- https://github.com/asterisk/asterisk/commit/42a2f4ccfa2c7062a15063e765916b3332e34cc4 x_refsource_MISC
- https://github.com/asterisk/asterisk/commit/4f01669c7c41c9184f3cce9a3cf1b2ebf6201742 x_refsource_MISC
- https://github.com/asterisk/asterisk/commit/50bf8d4d3064930d28ecf1ce3397b14574d514d2 x_refsource_MISC
- https://github.com/asterisk/asterisk/commit/7a0090325bfa9d778a39ae5f7d0a98109e4651c8 x_refsource_MISC
- https://github.com/asterisk/asterisk/commit/a15050650abf09c10a3c135fab148220cd41d3a0 x_refsource_MISC
- https://lists.debian.org/debian-lts-announce/2024/10/msg00016.html