Vulnerability · Published Aug 15, 2024 · Assigned by GitHub_M

CVE-2024-42472Flatpak may allow access to files outside sandbox for certain apps

Critical 10.0

In plain English

A critical-severity injection in flatpak from flatpak. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)1.3%top 30.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Flatpak is a Linux application sandboxing and distribution framework. Prior to versions 1.14.0 and 1.15.10, a malicious or compromised Flatpak app using persistent directories could access and write files outside of what it would otherwise have access to, which is an attack on integrity and confidentiality. When `persistent=subdir` is used in the application permissions (represented as `--persist=subdir` in the command-line interface), that means that an application which otherwise doesn't have access to the real user home directory will see an empty home directory with a writeable subdirectory `subdir`. Behind the scenes, this directory is actually a bind mount and the data is stored in the per-application directory as `~/.var/app/$APPID/subdir`. This allows existing apps that are not aware of the per-application directory to still work as intended without general home directory access. However, the application does have write access to the application directory `~/.var/app/$APPID` where this directory is stored. If the source directory for the `persistent`/`--persist` option is replaced by a symlink, then the next time the application is started, the bind mount will follow the symlink and mount whatever it points to into the sandbox. Partial protection against this vulnerability can be provided by patching Flatpak using the patches in commits ceec2ffc and 98f79773. However, this leaves a race condition that could be exploited by two instances of a malicious app running in parallel. Closing the race condition requires updating or patching the version of bubblewrap that is used by Flatpak to add the new `--bind-fd` option using the patch and then patching Flatpak to use it. If Flatpak has been configured at build-time with `-Dsystem_bubblewrap=bwrap` (1.15.x) or `--with-system-bubblewrap=bwrap` (1.14.x or older), or a similar option, then the version of bubblewrap that needs to be patched is a system copy that is distributed separately, typically `/usr/bin/bwrap`. This configuration is the one that is typically used in Linux distributions. If Flatpak has been configured at build-time with `-Dsystem_bubblewrap=` (1.15.x) or with `--without-system-bubblewrap` (1.14.x or older), then it is the bundled version of bubblewrap that is included with Flatpak that must be patched. This is typically installed as `/usr/libexec/flatpak-bwrap`. This configuration is the default when building from source code. For the 1.14.x stable branch, these changes are included in Flatpak 1.14.10. The bundled version of bubblewrap included in this release has been updated to 0.6.3. For the 1.15.x development branch, these changes are included in Flatpak 1.15.10. The bundled version of bubblewrap in this release is a Meson "wrap" subproject, which has been updated to 0.10.0. The 1.12.x and 1.10.x branches will not be updated for this vulnerability. Long-term support OS distributions should backport the individual changes into their versions of Flatpak and bubblewrap, or update to newer versions if their stability policy allows it. As a workaround, avoid using applications using the `persistent` (`--persist`) permission.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8bubblewrap0.4.0-2.el8_10ALSA-2024:6422
AlmaLinux:9bubblewrap0.4.1-7.el9_4.alma.1ALSA-2024:6356
AlmaLinux:9bubblewrap0.4.1-8.el9_5ALSA-2024:9449
AlmaLinux:8flatpak1.12.9-3.el8_10ALSA-2024:6422
AlmaLinux:9flatpak1.12.9-3.el9_5ALSA-2024:9449
AlmaLinux:9flatpak1.12.9-3.el9_4ALSA-2024:6356
AlmaLinux:8flatpak-devel1.12.9-3.el8_10ALSA-2024:6422
AlmaLinux:9flatpak-devel1.12.9-3.el9_5ALSA-2024:9449
AlmaLinux:9flatpak-devel1.12.9-3.el9_4ALSA-2024:6356
AlmaLinux:8flatpak-libs1.12.9-3.el8_10ALSA-2024:6422
AlmaLinux:9flatpak-libs1.12.9-3.el9_4ALSA-2024:6356
AlmaLinux:9flatpak-libs1.12.9-3.el9_5ALSA-2024:9449
AlmaLinux:8flatpak-selinux1.12.9-3.el8_10ALSA-2024:6422
AlmaLinux:9flatpak-selinux1.12.9-3.el9_4ALSA-2024:6356
AlmaLinux:9flatpak-selinux1.12.9-3.el9_5ALSA-2024:9449
AlmaLinux:8flatpak-session-helper1.12.9-3.el8_10ALSA-2024:6422
AlmaLinux:9flatpak-session-helper1.12.9-3.el9_4ALSA-2024:6356
AlmaLinux:9flatpak-session-helper1.12.9-3.el9_5ALSA-2024:9449
Alpine:v3.20bubblewrap0.10.0-r0ALPINE-CVE-2024-42472
Alpine:v3.21bubblewrap0.10.0-r0ALPINE-CVE-2024-42472
Alpine:v3.22bubblewrap0.10.0-r0ALPINE-CVE-2024-42472
Alpine:v3.23bubblewrap0.10.0-r0ALPINE-CVE-2024-42472
Alpine:v3.24bubblewrap0.10.0-r0ALPINE-CVE-2024-42472
Alpine:v3.20flatpak1.14.10-r0ALPINE-CVE-2024-42472
Alpine:v3.21flatpak1.14.10-r0ALPINE-CVE-2024-42472
Alpine:v3.22flatpak1.14.10-r0ALPINE-CVE-2024-42472
Alpine:v3.23flatpak1.14.10-r0ALPINE-CVE-2024-42472
Alpine:v3.24flatpak1.14.10-r0ALPINE-CVE-2024-42472
Debian:12flatpak1.14.10-1~deb12u1DEBIAN-CVE-2024-42472
Debian:12flatpak1.14.10-1~deb12u1DSA-5749-1
Debian:13flatpak1.14.10-1DEBIAN-CVE-2024-42472
Debian:14flatpak1.14.10-1DEBIAN-CVE-2024-42472
Rocky Linux:8bubblewrap0:0.4.0-2.el8_10RLSA-2024:6422
Rocky Linux:9bubblewrap0:0.4.1-8.el9_5RLSA-2024:9449
Rocky Linux:8flatpak0:1.12.9-3.el8_10RLSA-2024:6422
Rocky Linux:9flatpak0:1.12.9-3.el9_5RLSA-2024:6356
Ubuntu:22.04:LTSbubblewrap0.6.1-1ubuntu0.1USN-7046-1
Ubuntu:24.04:LTSbubblewrap0.9.0-1ubuntu0.1USN-7046-1
Ubuntu:22.04:LTSflatpak1.12.7-1ubuntu0.1USN-7046-1
Ubuntu:22.04:LTSflatpak1.12.7-1ubuntu0.1UBUNTU-CVE-2024-42472
Ubuntu:24.04:LTSflatpak1.14.6-1ubuntu0.1USN-7046-1
Ubuntu:24.04:LTSflatpak1.14.6-1ubuntu0.1UBUNTU-CVE-2024-42472

Affected products (as reported)

VendorProductVersions
flatpak flatpak < 1.14.10>= 1.15.0, < 1.15.10

Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

References