Vulnerability · Published Aug 9, 2024 · Assigned by GitHub_M
CVE-2024-42469CometVisu Backend for openHAB affected by RCE through path traversal
Critical 9.8
In plain English
A critical-severity path traversal in openhab-webui from openhab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. Prior to version 4.2.1, CometVisu's file system endpoints don't require authentication and additionally the endpoint to update an existing file is susceptible to path traversal. This makes it possible for an attacker to overwrite existing files on the openHAB instance. If the overwritten file is a shell script that is executed at a later time, this vulnerability can allow remote code execution by an attacker. Users should upgrade to version 4.2.1 to receive a patch.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.openhab.ui.bundles:org.openhab.ui.cometvisu | 4.2.1 | GHSA-f729-58x4-gqgf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| openhab | openhab-webui | < 4.2.1 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H