Vulnerability · Published Aug 9, 2024 · Assigned by GitHub_M
CVE-2024-42468Path traversal (CometVisu)
Medium 5.3
In plain English
A medium-severity path traversal in openhab-webui from openhab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. CometVisuServlet in versions prior to 4.2.1 is susceptible to an unauthenticated path traversal vulnerability. Local files on the server can be requested via HTTP GET on the CometVisuServlet. This issue may lead to information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.openhab.ui.bundles:org.openhab.ui.cometvisu | 4.2.1 | GHSA-pcwp-26pw-j98w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| openhab | openhab-webui | < 4.2.1 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/openhab/openhab-webui/security/advisories/GHSA-pcwp-26pw-j98w x_refsource_CONFIRM
- https://github.com/openhab/openhab-webui/commit/630e8525835c698cf58856aa43782d92b18087f2 x_refsource_MISC
- https://github.com/openhab/openhab-webui/blob/1c03c60f84388b9d7da0231df2d4ebb1e17d3fcf/bundles/org.openhab.ui.cometvisu/src/main/java/org/openhab/ui/cometvisu/internal/servlet/CometVisuServlet.java#L75 x_refsource_MISC