Vulnerability · Published Aug 8, 2024 · Assigned by GitHub_M

CVE-2024-42355Shopware vulnerable to Server Side Template Injection in Twig using deprecation silence tag

High 8.3

In plain English

A high-severity security flaw in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.9%top 41.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware, an open ecommerce platform, has a new Twig Tag `sw_silent_feature_call` which silences deprecation messages while triggered in this tag. Prior to versions 6.6.5.1 and 6.5.8.13, it accepts as parameter a string the feature flag name to silence, but this parameter is not escaped properly and allows execution of code. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.5.8.13GHSA-27wp-jvhw-v4xp
Packagistshopware/core6.6.5.1GHSA-27wp-jvhw-v4xp
Packagistshopware/platform6.5.8.13GHSA-27wp-jvhw-v4xp
Packagistshopware/platform6.6.5.1GHSA-27wp-jvhw-v4xp

Affected products (as reported)

VendorProductVersions
shopware shopware <= 6.5.8.12>= 6.6.0.0, <= 6.6.5.0

Weakness: CWE-1336 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

References