Vulnerability · Published Aug 8, 2024 · Assigned by GitHub_M

CVE-2024-42354Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api

Medium 5.3

In plain English

A medium-severity improper access control in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.4%top 62.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open commerce platform. The store-API works with regular entities and not expose all fields for the public API; fields need to be marked as ApiAware in the EntityDefinition. So only ApiAware fields of the EntityDefinition will be encoded to the final JSON. Prior to versions 6.6.5.1 and 6.5.8.13, the processing of the Criteria did not considered ManyToMany associations and so they were not considered properly and the protections didn't get used. This issue cannot be reproduced with the default entities by Shopware, but can be triggered with extensions. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.5.8.13GHSA-hhcq-ph6w-494g
Packagistshopware/core6.6.5.1GHSA-hhcq-ph6w-494g
Packagistshopware/platform6.5.8.13GHSA-hhcq-ph6w-494g
Packagistshopware/platform6.6.5.1GHSA-hhcq-ph6w-494g

Affected products (as reported)

VendorProductVersions
shopware shopware <= 6.5.8.12>= 6.6.0.0, <= 6.6.5.0

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

References