Vulnerability · Published Aug 29, 2024 · Assigned by GitHub_M

CVE-2024-41964Insufficient permission checks in the language settings in Kirby CMS

High 8.1

In plain English

A high-severity incorrect authorization in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 58.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is a CMS targeting designers and editors. Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages.* wildcard permission for a role could not have prohibited updates to existing language definitions. The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The problem has been patched in Kirby 3.6.6.6, Kirby 3.7.5.5, Kirby 3.8.4.4, Kirby 3.9.8.2, Kirby 3.10.1.1, and Kirby 4.3.1. Please update to one of these or a later version to fix the vulnerability. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms3.6.6.6GHSA-jm9m-rqr3-wfmh
Packagistgetkirby/cms3.7.5.5GHSA-jm9m-rqr3-wfmh
Packagistgetkirby/cms3.8.4.4GHSA-jm9m-rqr3-wfmh
Packagistgetkirby/cms3.9.8.2GHSA-jm9m-rqr3-wfmh
Packagistgetkirby/cms3.10.1.1GHSA-jm9m-rqr3-wfmh
Packagistgetkirby/cms4.3.1GHSA-jm9m-rqr3-wfmh

Affected products (as reported)

VendorProductVersions
getkirby kirby < 3.6.6.6>= 3.7.0, < 3.7.5.5>= 3.8.0, < 3.8.4.4>= 3.9.0, < 3.9.8.2>= 3.10.0, < 3.10.1.1>= 4.0.0, < 4.3.1

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

References