Vulnerability · Published Aug 1, 2024 · Assigned by GitHub_M

CVE-2024-41962Bostr Improper Authorization

Medium 4.6

In plain English

A medium-severity security flaw in bostr from Yonle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.6Medium
Exploit odds (30 days)0.3%top 77.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Bostr is an nostr relay aggregator proxy that acts like a regular nostr relay. bostr let everyone in even having authorized_keys being set when noscraper is set to true. This vulnerability is fixed in 3.0.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmbostr3.0.10GHSA-5cf7-cxrf-mq73

Affected products (as reported)

VendorProductVersions
Yonle bostr < 3.0.10

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L

References