Vulnerability · Published Jul 31, 2024 · Assigned by GitHub_M

CVE-2024-41950Insecure Jinja2 templates rendered in Haystack Components can lead to RCE

High 7.5

In plain English

A high-severity security flaw in haystack from deepset-ai. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.2%top 32.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Haystack is an end-to-end LLM framework that allows you to build applications powered by LLMs, Transformer models, vector search and more. Haystack clients that let their users create and run Pipelines from scratch are vulnerable to remote code executions. Certain Components in Haystack use Jinja2 templates, if anyone can create and render that template on the client machine they run any code. The vulnerability has been fixed with Haystack `2.3.1`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIhaystack-ai2.3.1GHSA-hx9v-6r9f-w677
PyPIhaystack-ai2.3.1PYSEC-2026-1447

Affected products (as reported)

VendorProductVersions
deepset-ai haystack < 2.3.1

Weakness: CWE-1336 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References