Vulnerability · Published Aug 21, 2024 · Assigned by apache

CVE-2024-41937Apache Airflow: Stored XSS Vulnerability on provider link

Medium 6.1

In plain English

A medium-severity cross-site scripting in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)1.7%top 22.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow2.10.0GHSA-w7cp-g8v7-r54m
PyPIapache-airflow2.10.0PYSEC-2024-181

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow 0 – before 2.10.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References