Vulnerability · Published May 16, 2024 · Assigned by @huntr_ai

CVE-2024-4181Command Injection in run-llama/llama_index

High 8.8

In plain English

A high-severity code injection in run-llama/llama_index from run-llama. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)8.8High
Exploit odds (30 days)2.1%top 17.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIllama-index0.10.13GHSA-pw38-xv9x-h8ch
PyPIllama-index0.10.13PYSEC-2024-324
PyPIllama-index-llms-rungpt0.1.3GHSA-pw38-xv9x-h8ch
PyPIllama-index-llms-rungpt0.1.3PYSEC-2026-1565

Affected products (as reported)

VendorProductVersions
run-llama run-llama/llama_index unspecified – before 0.10.13

Weakness: CWE-94 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References