Vulnerability · Published Jul 29, 2024 · Assigned by GitHub_M

CVE-2024-41676Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configs

Medium 4.1

In plain English

A medium-severity cross-site scripting in magento-lts from OpenMage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.1Medium
Exploit odds (30 days)0.4%top 70.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). This XSS vulnerability affects the design/header/welcome, design/header/logo_src, design/header/logo_src_small, and design/header/logo_alt system configs.They are intended to enable admins to set a text in the two cases, and to define an image url for the other two cases. But because of previously missing escaping allowed to input arbitrary html and as a consequence also arbitrary JavaScript. The problem is patched with Version 20.10.1 or higher.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistopenmage/magento-lts20.10.1GHSA-5vrp-638w-p8m2

Affected products (as reported)

VendorProductVersions
OpenMage magento-lts < 20.10.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N

References