Vulnerability · Published Aug 21, 2024 · Assigned by GitHub_M

CVE-2024-41675CKAN has a Cross-site Scripting vector in the Datatables view plugin

Medium 6.8

In plain English

A medium-severity cross-site scripting in ckan from ckan. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.8Medium
Exploit odds (30 days)0.4%top 65.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

CKAN is an open-source data management system for powering data hubs and data portals. The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector. Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data. This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIckan2.10.5GHSA-r3jc-vhf4-6v32
PyPIckan2.10.5PYSEC-2026-1253

Affected products (as reported)

VendorProductVersions
ckan ckan >= 2.7.0, < 2.10.5

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N

References