Vulnerability · Published Oct 1, 2024 · Assigned by GitHub_M

CVE-2024-41673Decidim has a cross-site scripting vulnerability in the version control page

High 7.1

In plain English

A high-severity cross-site scripting in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.4%top 63.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. The version control feature used in resources is subject to potential XSS attack through a malformed URL. This vulnerability is fixed in 0.27.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim0.27.8GHSA-cc4g-m3g7-xmw8

Affected products (as reported)

VendorProductVersions
decidim decidim < 0.27.8

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

References