Vulnerability · Published Jul 29, 2024 · Assigned by GitHub_M

CVE-2024-41671twisted.web has disordered HTTP pipeline response

High 8.3

In plain English

A high-severity security flaw in twisted from twisted. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.9%top 41.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. The HTTP 1.0 and 1.1 server provided by twisted.web could process pipelined HTTP requests out-of-order, possibly resulting in information disclosure. This vulnerability is fixed in 24.7.0rc1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20synapse1.112.0-r0ALPINE-CVE-2024-41671
Alpine:v3.21synapse1.112.0-r0ALPINE-CVE-2024-41671
Alpine:v3.22synapse1.112.0-r0ALPINE-CVE-2024-41671
Alpine:v3.23synapse1.112.0-r0ALPINE-CVE-2024-41671
Alpine:v3.24synapse1.112.0-r0ALPINE-CVE-2024-41671
Debian:12twisted22.4.0-4+deb12u1DEBIAN-CVE-2024-41671
Debian:12twisted22.4.0-4+deb12u1DSA-5797-1
Debian:13twisted24.7.0-1DEBIAN-CVE-2024-41671
Debian:14twisted24.7.0-1DEBIAN-CVE-2024-41671
PyPItwisted24.7.0rc1GHSA-c8m8-j448-xjx7
PyPItwisted24.7.0rc1PYSEC-2026-1992
Ubuntu:22.04:LTStwisted22.1.0-2ubuntu2.5USN-6988-1
Ubuntu:22.04:LTStwisted22.1.0-2ubuntu2.6USN-6988-2
Ubuntu:22.04:LTStwisted22.1.0-2ubuntu2.6UBUNTU-CVE-2024-41671
Ubuntu:24.04:LTStwisted24.3.0-1ubuntu0.1UBUNTU-CVE-2024-41671
Ubuntu:24.04:LTStwisted24.3.0-1ubuntu0.1USN-6988-1

Affected products (as reported)

VendorProductVersions
twisted twisted <= 24.3.0

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

References