Vulnerability · Published Jul 12, 2025 · Assigned by apache
CVE-2024-41169Apache Zeppelin: raft directory listing and file read
High 7.5
In plain English
A high-severity security flaw in Apache Zeppelin from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files. This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.zeppelin:zeppelin-interpreter | 0.12.0 | GHSA-7pgf-ppxw-8624 |
| Maven | org.apache.zeppelin:zeppelin-server | 0.12.0 | GHSA-7pgf-ppxw-8624 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Zeppelin | 0.10.1 – before 0.12.0 |
Weakness: CWE-664 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N