Vulnerability · Published Jul 16, 2024 · Assigned by GitHub_M

CVE-2024-40637Implicit override for built-in materializations from installed packages in dbt-core

Medium 4.2

In plain English

A medium-severity injection in dbt-core from dbt-labs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.2Medium
Exploit odds (30 days)0.4%top 68.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. When a user installs a package in dbt, it has the ability to override macros, materializations, and other core components of dbt. This is by design, as it allows packages to extend and customize dbt's functionality. However, this also means that a malicious package could potentially override these components with harmful code. This issue has been fixed in versions 1.8.0, 1.6.14 and 1.7.14. Users are advised to upgrade. There are no kn own workarounds for this vulnerability. Users updating to either 1.6.14 or 1.7.14 will need to set `flags.require_explicit_package_overrides_for_builtin_materializations: False` in their configuration in `dbt_project.yml`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIdbt-core1.6.14GHSA-p3f3-5ccg-83xq
PyPIdbt-core1.7.14GHSA-p3f3-5ccg-83xq
PyPIdbt-core1.6.14, 1.7.14PYSEC-2024-66

Affected products (as reported)

VendorProductVersions
dbt-labs dbt-core < 1.6.14>= 1.7.0, < 1.7.14

Weakness: CWE-74 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L

References