Vulnerability · Published Jul 17, 2024 · Assigned by GitHub_M

CVE-2024-40633Customer data leak via adjustments API endpoint in Sylius

Medium 5.3

In plain English

A medium-severity information exposure in Sylius from Sylius. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.4%top 67.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Sylius is an Open Source eCommerce Framework on Symfony. A security vulnerability was discovered in the `/api/v2/shop/adjustments/{id}` endpoint, which retrieves order adjustments based on incremental integer IDs. The vulnerability allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details - sensitive guest customer information. The issue is fixed in versions: 1.12.19, 1.13.4 and above. The `/api/v2/shop/adjustments/{id}` will always return `404` status. Users are advised to upgrade. Users unable to upgrade may alter their config to mitigate this issue. Please see the linked GHSA for details.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistsylius/sylius1.12.19GHSA-55rf-8q29-4g43
Packagistsylius/sylius1.13.4GHSA-55rf-8q29-4g43
Packagistsylius/sylius1.9.12GHSA-55rf-8q29-4g43
Packagistsylius/sylius1.10.16GHSA-55rf-8q29-4g43
Packagistsylius/sylius1.11.17GHSA-55rf-8q29-4g43

Affected products (as reported)

VendorProductVersions
Sylius Sylius < 1.12.19>= 1.13.0, < 1.13.4

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References