Vulnerability · Published Jul 17, 2024 · Assigned by apache

CVE-2024-39863Apache Airflow: Potential XSS Vulnerability

High 8.1

In plain English

A high-severity cross-site scripting in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)1.0%top 37.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow2.9.3GHSA-j482-47xf-p25c
PyPIapache-airflow2.9.3PYSEC-2024-189

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow 0 – before 2.9.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References