Vulnerability · Published Jul 30, 2024 · Assigned by GitHub_M

CVE-2024-39320Discourse allows iframe injection though default site setting

Medium 6.1

In plain English

A medium-severity injection in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities).

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.3%top 71.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.

Affected products (as reported)

VendorProductVersions
discourse discourse < 3.2.5>= 3.3.0.beta1, < 3.3.0.beta5

Weakness: CWE-74, CWE-1021 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References