Vulnerability · Published Jul 11, 2024 · Assigned by GitHub_M

CVE-2024-39317Wagtail regular expression denial-of-service via search query parsing

Medium 6.5

In plain English

A medium-severity regular-expression denial of service in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.6%top 50.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Wagtail is an open source content management system built on Django. A bug in Wagtail's `parse_query_string` would result in it taking a long time to process suitably crafted inputs. When used to parse sufficiently long strings of characters without a space, `parse_query_string` would take an unexpectedly large amount of time to process, resulting in a denial of service. In an initial Wagtail installation, the vulnerability can be exploited by any Wagtail admin user. It cannot be exploited by end users. If your Wagtail site has a custom search implementation which uses `parse_query_string`, it may be exploitable by other users (e.g. unauthenticated users). Patched versions have been released as Wagtail 5.2.6, 6.0.6 and 6.1.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIwagtail6.0.6GHSA-jmp3-39vp-fwg8
PyPIwagtail6.1.3GHSA-jmp3-39vp-fwg8
PyPIwagtail5.2.6GHSA-jmp3-39vp-fwg8
PyPIwagtail5.2.6, 6.0.6, 6.1.3PYSEC-2024-86

Affected products (as reported)

VendorProductVersions
wagtail wagtail >= 2.0, < 5.2.6>= 6.0, < 6.0.6>= 6.1, < 6.1.3

Weakness: CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References