Vulnerability · Published Jul 8, 2024 · Assigned by GitHub_M

CVE-2024-39308RailsAdmin Cross-site Scripting vulnerability in the list view

Medium 6.8

In plain English

A medium-severity cross-site scripting in rails_admin from railsadminteam. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)6.8Medium
Exploit odds (30 days)0.6%top 52.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RailsAdmin is a Rails engine that provides an interface for managing data. RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. Upgrade to 3.1.3 or 2.2.2 (to be released).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsrails_admin3.1.3GHSA-8qgm-g2vv-vwvc

Affected products (as reported)

VendorProductVersions
railsadminteam rails_admin >= 3.0.0, < 3.1.3< 2.3.0

Weakness: CWE-79 · Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N

References