Vulnerability · Published Jul 22, 2024 · Assigned by apache
CVE-2024-38503Apache Syncope: HTML tags can be injected into Console or Enduser text fields
Low 3.9
In plain English
A low-severity cross-site scripting in Apache Syncope from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing “Personal Information” or “User Requests”. Users are recommended to upgrade to version 3.0.8, which fixes this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui | 3.0.8 | GHSA-8pxv-x6jq-5vw9 |
| Maven | org.apache.syncope.client.idrepo:syncope-client-idrepo-console | 3.0.8 | GHSA-8pxv-x6jq-5vw9 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Syncope | 2.1 – through 2.1.143.0 – through 3.0.7 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N