Vulnerability · Published Nov 14, 2024 · Assigned by apache
CVE-2024-38479Apache Traffic Server: Cache key plugin is vulnerable to cache poisoning attack
High 7.5
In plain English
A high-severity improper input validation in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.5. Users are recommended to upgrade to version 9.2.6, which fixes the issue, or 10.0.2, which does not have the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | trafficserver9 | 9.2.6-r0 | ALPINE-CVE-2024-38479 |
| Alpine:v3.22 | trafficserver9 | 9.2.6-r0 | ALPINE-CVE-2024-38479 |
| Alpine:v3.23 | trafficserver9 | 9.2.6-r0 | ALPINE-CVE-2024-38479 |
| Alpine:v3.24 | trafficserver9 | 9.2.6-r0 | ALPINE-CVE-2024-38479 |
| Debian:12 | trafficserver | 9.2.5+ds-0+deb12u2 | DEBIAN-CVE-2024-38479 |
| Debian:12 | trafficserver | 9.2.5+ds-0+deb12u2 | DSA-5896-1 |
| Ubuntu:24.04:LTS | trafficserver | no fix listed | UBUNTU-CVE-2024-38479 |
| Ubuntu:25.10 | trafficserver | no fix listed | UBUNTU-CVE-2024-38479 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Traffic Server | 8.0.0 – through 8.1.119.0.0 – through 9.2.5 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N