Vulnerability · Published Jul 1, 2024 · Assigned by apache

CVE-2024-38476Apache HTTP Server may use exploitable/malicious backend application output to run local handlers via internal redirect

Critical 9.8

In plain English

A critical-severity security flaw in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 41.6% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)41.6%top 1.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Vulnerability in core of Apache HTTP Server 2.4.59 and earlier are vulnerably to information disclosure, SSRF or local script execution via backend applications whose response headers are malicious or exploitable. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8httpd2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9httpd2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:9httpd-core2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8httpd-devel2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9httpd-devel2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8httpd-filesystem2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9httpd-filesystem2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8httpd-manual2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9httpd-manual2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8httpd-tools2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9httpd-tools2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+3872+9b8ab21eALSA-2024:5193
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+3832+564e7653ALSA-2024:5193
AlmaLinux:8mod_ldap2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9mod_ldap2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:9mod_lua2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8mod_md1:2.0.8-8.module_el8.6.0+3031+fb177b09ALSA-2024:5193
AlmaLinux:8mod_md1:2.0.8-8.module_el8.6.0+2872+fe0ff7aaALSA-2024:5193
AlmaLinux:8mod_proxy_html1:2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9mod_proxy_html1:2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8mod_session2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9mod_session2.4.57-11.el9_4.1ALSA-2024:5138
AlmaLinux:8mod_ssl1:2.4.37-65.module_el8.10.0+3874+c2064c23.2ALSA-2024:5193
AlmaLinux:9mod_ssl1:2.4.57-11.el9_4.1ALSA-2024:5138
Alpine:v3.20apache22.4.60-r0ALPINE-CVE-2024-38476
Alpine:v3.21apache22.4.60-r0ALPINE-CVE-2024-38476
Alpine:v3.22apache22.4.60-r0ALPINE-CVE-2024-38476
Alpine:v3.23apache22.4.60-r0ALPINE-CVE-2024-38476
Alpine:v3.24apache22.4.60-r0ALPINE-CVE-2024-38476
Debian:12apache22.4.61-1~deb12u1DEBIAN-CVE-2024-38476
Debian:12apache22.4.61-1~deb12u1DSA-5729-1
Debian:13apache22.4.60-1DEBIAN-CVE-2024-38476
Debian:14apache22.4.60-1DEBIAN-CVE-2024-38476
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1830+22f0c9e0RLSA-2024:5193
Rocky Linux:9httpd0:2.4.57-11.el9_4.1RLSA-2024:5138
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1775+6b057638RLSA-2024:5193
Rocky Linux:8mod_md1:2.0.8-8.module+el8.9.0+1370+89cc8ad5RLSA-2024:5193
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.10USN-6885-1
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.10UBUNTU-CVE-2024-38476
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.2USN-6885-1
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.2UBUNTU-CVE-2024-38476

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 2.4.0 – through 2.4.59

Weakness: CWE-829 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References