Vulnerability · Published Jul 1, 2024 · Assigned by apache

CVE-2024-38474Apache HTTP Server weakness with encoded question marks in backreferences

High 8.1

In plain English

A high-severity security flaw in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 84% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)2.5%top 15.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8httpd2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9httpd2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:9httpd-core2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8httpd-devel2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9httpd-devel2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8httpd-filesystem2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9httpd-filesystem2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8httpd-manual2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9httpd-manual2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8httpd-tools2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9httpd-tools2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+3832+564e7653ALSA-2024:4720
AlmaLinux:8mod_ldap2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9mod_ldap2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:9mod_lua2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8mod_md1:2.0.8-8.module_el8.6.0+3031+fb177b09ALSA-2024:4720
AlmaLinux:8mod_md1:2.0.8-8.module_el8.6.0+2872+fe0ff7aaALSA-2024:4720
AlmaLinux:8mod_proxy_html1:2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9mod_proxy_html1:2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8mod_session2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9mod_session2.4.57-11.el9_4ALSA-2024:4726
AlmaLinux:8mod_ssl1:2.4.37-65.module_el8.10.0+3872+9b8ab21e.1ALSA-2024:4720
AlmaLinux:9mod_ssl1:2.4.57-11.el9_4ALSA-2024:4726
Alpine:v3.20apache22.4.60-r0ALPINE-CVE-2024-38474
Alpine:v3.21apache22.4.60-r0ALPINE-CVE-2024-38474
Alpine:v3.22apache22.4.60-r0ALPINE-CVE-2024-38474
Alpine:v3.23apache22.4.60-r0ALPINE-CVE-2024-38474
Alpine:v3.24apache22.4.60-r0ALPINE-CVE-2024-38474
Debian:12apache22.4.61-1~deb12u1DEBIAN-CVE-2024-38474
Debian:12apache22.4.61-1~deb12u1DSA-5729-1
Debian:13apache22.4.60-1DEBIAN-CVE-2024-38474
Debian:14apache22.4.60-1DEBIAN-CVE-2024-38474
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2RLSA-2024:4720
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1840+b070a976.1RLSA-2024:4720
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3RLSA-2024:4720
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1830+22f0c9e0RLSA-2024:4720
Rocky Linux:9httpd0:2.4.57-11.el9_4RLSA-2024:4726
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1883+38ed6c58.1RLSA-2024:4720
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1830+22f0c9e0RLSA-2024:4720
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1775+6b057638RLSA-2024:4720
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1938+3b7755d4.3RLSA-2024:4720
Rocky Linux:8mod_md1:2.0.8-8.module+el8.9.0+1370+89cc8ad5RLSA-2024:4720
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.10USN-6885-1
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.16UBUNTU-CVE-2024-38474
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.8UBUNTU-CVE-2024-38474
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.2USN-6885-1

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 2.4.0 – through 2.4.59

Weakness: CWE-116 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

References