Vulnerability · Published Jul 1, 2024 · Assigned by apache
CVE-2024-38473Apache HTTP Server proxy encoding problem
High 8.1
In plain English
A high-severity security flaw in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 25.9% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | httpd | 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | httpd | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:9 | httpd-core | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | httpd-devel | 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | httpd-devel | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | httpd-filesystem | 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | httpd-filesystem | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | httpd-manual | 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | httpd-manual | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | httpd-tools | 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | httpd-tools | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | mod_http2 | 1.15.7-10.module_el8.10.0+3832+564e7653 | ALSA-2024:4720 |
| AlmaLinux:8 | mod_ldap | 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | mod_ldap | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:9 | mod_lua | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | mod_md | 1:2.0.8-8.module_el8.6.0+3031+fb177b09 | ALSA-2024:4720 |
| AlmaLinux:8 | mod_md | 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa | ALSA-2024:4720 |
| AlmaLinux:8 | mod_proxy_html | 1:2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | mod_proxy_html | 1:2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | mod_session | 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | mod_session | 2.4.57-11.el9_4 | ALSA-2024:4726 |
| AlmaLinux:8 | mod_ssl | 1:2.4.37-65.module_el8.10.0+3872+9b8ab21e.1 | ALSA-2024:4720 |
| AlmaLinux:9 | mod_ssl | 1:2.4.57-11.el9_4 | ALSA-2024:4726 |
| Alpine:v3.20 | apache2 | 2.4.60-r0 | ALPINE-CVE-2024-38473 |
| Alpine:v3.21 | apache2 | 2.4.60-r0 | ALPINE-CVE-2024-38473 |
| Alpine:v3.22 | apache2 | 2.4.60-r0 | ALPINE-CVE-2024-38473 |
| Alpine:v3.23 | apache2 | 2.4.60-r0 | ALPINE-CVE-2024-38473 |
| Alpine:v3.24 | apache2 | 2.4.60-r0 | ALPINE-CVE-2024-38473 |
| Debian:12 | apache2 | 2.4.61-1~deb12u1 | DEBIAN-CVE-2024-38473 |
| Debian:12 | apache2 | 2.4.61-1~deb12u1 | DSA-5729-1 |
| Debian:13 | apache2 | 2.4.60-1 | DEBIAN-CVE-2024-38473 |
| Debian:14 | apache2 | 2.4.60-1 | DEBIAN-CVE-2024-38473 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2 | RLSA-2024:4720 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1840+b070a976.1 | RLSA-2024:4720 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3 | RLSA-2024:4720 |
| Rocky Linux:8 | httpd | 0:2.4.37-65.module+el8.10.0+1830+22f0c9e0 | RLSA-2024:4720 |
| Rocky Linux:9 | httpd | 0:2.4.57-11.el9_4 | RLSA-2024:4726 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1883+38ed6c58.1 | RLSA-2024:4720 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1830+22f0c9e0 | RLSA-2024:4720 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1775+6b057638 | RLSA-2024:4720 |
| Rocky Linux:8 | mod_http2 | 0:1.15.7-10.module+el8.10.0+1938+3b7755d4.3 | RLSA-2024:4720 |
| Rocky Linux:8 | mod_md | 1:2.0.8-8.module+el8.9.0+1370+89cc8ad5 | RLSA-2024:4720 |
| Ubuntu:22.04:LTS | apache2 | 2.4.52-1ubuntu4.10 | USN-6885-1 |
| Ubuntu:22.04:LTS | apache2 | 2.4.52-1ubuntu4.10 | UBUNTU-CVE-2024-38473 |
| Ubuntu:24.04:LTS | apache2 | 2.4.58-1ubuntu8.2 | UBUNTU-CVE-2024-38473 |
| Ubuntu:24.04:LTS | apache2 | 2.4.58-1ubuntu8.2 | USN-6885-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache HTTP Server | 2.4.0 – through 2.4.59 |
Weakness: CWE-116 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H