Vulnerability · Published Jul 8, 2024 · Assigned by GitHub_M

CVE-2024-38372Undici vulnerable to data leak when using response.arrayBuffer()

Low 2.0

In plain English

A low-severity security flaw in undici from nodejs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.0Low
Exploit odds (30 days)0.5%top 59.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Undici is an HTTP/1.1 client, written from scratch for Node.js. Depending on network and process conditions of a `fetch()` request, `response.arrayBuffer()` might include portion of memory from the Node.js process. This has been patched in v6.19.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2024-38372
Ubuntu:25.10node-undicino fix listedUBUNTU-CVE-2024-38372
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2024-38372
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2024-38372
npmundici6.19.2GHSA-3g92-w8c5-73pq

Affected products (as reported)

VendorProductVersions
nodejs undici >= 6.14.0, < 6.19.2

Weakness: CWE-201 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N

References