Vulnerability · Published Mar 6, 2025 · Assigned by apache
CVE-2024-38311Apache Traffic Server: Request smuggling via pipelining after a chunked message body
Medium 6.3
In plain English
A medium-severity improper input validation in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.8, from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 9.2.9 or 10.0.4, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | trafficserver | 9.2.5+ds-0+deb12u2 | DEBIAN-CVE-2024-38311 |
| Debian:12 | trafficserver | 9.2.5+ds-0+deb12u2 | DSA-5896-1 |
| Ubuntu:24.04:LTS | trafficserver | no fix listed | UBUNTU-CVE-2024-38311 |
| Ubuntu:25.10 | trafficserver | no fix listed | UBUNTU-CVE-2024-38311 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Traffic Server | 8.0.0 – through 8.1.119.0.0 – through 9.2.810.0.0 – through 10.0.3 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://lists.apache.org/thread/btofzws2yqskk2n7f01r3l1819x01023 vendor-advisory