Vulnerability · Published Nov 7, 2024 · Assigned by apache

CVE-2024-38286Apache Tomcat: Denial of Service

High 8.6

In plain English

A high-severity resource allocation without limits in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)1.7%top 22.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue. Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.87-1.el8_10.2ALSA-2024:5694
AlmaLinux:8tomcat-admin-webapps1:9.0.87-1.el8_10.2ALSA-2024:5694
AlmaLinux:8tomcat-docs-webapp1:9.0.87-1.el8_10.2ALSA-2024:5694
AlmaLinux:8tomcat-el-3.0-api1:9.0.87-1.el8_10.2ALSA-2024:5694
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.87-1.el8_10.2ALSA-2024:5694
AlmaLinux:8tomcat-lib1:9.0.87-1.el8_10.2ALSA-2024:5694
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.87-1.el8_10.2ALSA-2024:5694
AlmaLinux:8tomcat-webapps1:9.0.87-1.el8_10.2ALSA-2024:5694
Debian:12tomcat1010.1.34-0+deb12u1DEBIAN-CVE-2024-38286
Debian:12tomcat1010.1.34-0+deb12u1DSA-5845-1
Debian:13tomcat1010.1.25-1DEBIAN-CVE-2024-38286
Debian:14tomcat1010.1.25-1DEBIAN-CVE-2024-38286
Debian:12tomcat99.0.70-2DEBIAN-CVE-2024-38286
Debian:13tomcat99.0.70-2DEBIAN-CVE-2024-38286
Debian:14tomcat99.0.70-2DEBIAN-CVE-2024-38286
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.0-M21GHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.25GHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.90GHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat.embed:tomcat-embed-coreno fix listedGHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat.embed:tomcat-embed-coreno fix listedGHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat:tomcat-coyoteno fix listedGHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat:tomcat-coyoteno fix listedGHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat:tomcat-coyote9.0.90GHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat:tomcat-coyote10.1.25GHSA-7jqf-v358-p8g7
Mavenorg.apache.tomcat:tomcat-coyote11.0.0-M21GHSA-7jqf-v358-p8g7
Ubuntu:25.10tomcat99.0.70-2ubuntu3UBUNTU-CVE-2024-38286

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.0-M2010.1.0-M1 – through 10.1.249.0.13 – through 9.0.898.5.35 – through 8.5.1007.0.92 – through 7.0.109

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

References