Vulnerability · Published Jun 28, 2024 · Assigned by GitHub_M
CVE-2024-37905Improper Access Control and Incorrect Authorization in github.com/goauthentik/authentik
High 8.8
In plain English
A high-severity improper access control in authentik from goauthentik. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities).
Official description
authentik is an open-source Identity Provider that emphasizes flexibility and versatility. Authentik API-Access-Token mechanism can be exploited to gain admin user privileges. A successful exploit of the issue will result in a user gaining full admin access to the Authentik application, including resetting user passwords and more. This issue has been patched in version(s) 2024.2.4, 2024.4.2 and 2024.6.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| goauthentik | authentik | < 2024.6.0< 2024.4.2< 2024.2.4 |
Weakness: CWE-284, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/goauthentik/authentik/security/advisories/GHSA-c78c-2r9w-p7x4 x_refsource_CONFIRM
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.2.4 x_refsource_MISC
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.4.3 x_refsource_MISC
- https://github.com/goauthentik/authentik/releases/tag/version%2F2024.6.0 x_refsource_MISC