Vulnerability · Published Jun 20, 2024 · Assigned by GitHub_M
CVE-2024-37899Disabling a user account changes its author, allowing RCE from user account in XWiki
Critical 9.1
In plain English
A critical-severity code injection in xwiki-platform from xwiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account. To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add `{{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}`. As an admin, go to the user profile and click the "Disable this account" button. Then, reload the page. If the logs show `attacker - Hello from Groovy!` then the instance is vulnerable. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Users are advised to upgrade. There are no known workarounds for this vulnerability. ### Workarounds We're not aware of any workaround except upgrading. ### References * https://jira.xwiki.org/browse/XWIKI-21611 * https://github.com/xwiki/xwiki-platform/commit/f89c8f47fad6e5cc7e68c69a7e0acde07f5eed5a
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 14.10.21 | GHSA-j584-j2vj-3f93 |
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 14.10.21 | GHSA-j584-j2vj-3f93 |
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 15.5.5 | GHSA-j584-j2vj-3f93 |
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 15.10.6 | GHSA-j584-j2vj-3f93 |
| Maven | org.xwiki.platform:xwiki-platform-oldcore | 16.0.0 | GHSA-j584-j2vj-3f93 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki | xwiki-platform | >= 13.4.7, <= 13.5>= 13.10.3, < 14.10.21>= 15.0-rc-1, < 15.5.5>= 15.6-rc-1, < 15.10.6>= 16.0.0-rc-1, < 16.0.0 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-j584-j2vj-3f93 x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-platform/commit/f89c8f47fad6e5cc7e68c69a7e0acde07f5eed5a x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-21611 x_refsource_MISC