Vulnerability · Published Jun 17, 2024 · Assigned by GitHub_M
CVE-2024-37893MFA bypass in oauth flow in Firefly III
Medium 5.9
In plain English
A medium-severity improper authentication in firefly-iii from firefly-iii. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Firefly III is a free and open source personal finance manager. In affected versions an MFA bypass in the Firefly III OAuth flow may allow malicious users to bypass the MFA-check. This allows malicious users to use password spraying to gain access to Firefly III data using passwords stolen from other sources. As OAuth applications are easily enumerable using an incrementing id, an attacker could try sign an OAuth application up to a users profile quite easily if they have created one. The attacker would also need to know the victims username and password. This problem has been patched in Firefly III v6.1.17 and up. Users are advised to upgrade. Users unable to upgrade should Use a unique password for their Firefly III instance and store their password securely, i.e. in a password manager.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | grumpydictator/firefly-iii | 6.1.17 | GHSA-4gm4-c4mh-4p7w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| firefly-iii | firefly-iii | < 6.1.17 |
Weakness: CWE-287, CWE-288 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N