Vulnerability · Published Jun 14, 2024 · Assigned by GitHub_M
CVE-2024-37315Nextcloud Server's read-only users can restore old versions
Low 3.5
In plain English
A low-severity improper access control in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities).
Official description
Nextcloud Server is a self hosted personal cloud system. An attacker with read-only access to a file is able to restore older versions of a document when the files_versions app is enabled. It is recommended that the Nextcloud Server is upgraded to 26.0.12, 27.1.7 or 28.0.3 and that the Nextcloud Enterprise Server is upgraded to 23.0.12.16, 24.0.12.12, 25.0.13.6, 26.0.12, 27.1.7 or 28.0.3.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | >= 26.0.0, < 26.0.12>= 27.0.0, < 27.1.7>= 28.0.0, < 28.0.3 |
Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5mq8-738w-5942 x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/43727 x_refsource_MISC
- https://hackerone.com/reports/1356508 x_refsource_MISC