Vulnerability · Published Jun 17, 2024 · Assigned by GitHub_M
CVE-2024-37305Buffer overflow in deserialization in oqs-provider
High 8.2
In plain English
A high-severity buffer overflow in oqs-provider from open-quantum-safe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities).
Official description
oqs-provider is a provider for the OpenSSL 3 cryptography library that adds support for post-quantum cryptography in TLS, X.509, and S/MIME using post-quantum algorithms from liboqs. Flaws have been identified in the way oqs-provider handles lengths decoded with DECODE_UINT32 at the start of serialized hybrid (traditional + post-quantum) keys and signatures. Unchecked length values are later used for memory reads and writes; malformed input can lead to crashes or information leakage. Handling of plain/non-hybrid PQ key operation is not affected. This issue has been patched in in v0.6.1. All users are advised to upgrade. There are no workarounds for this issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| open-quantum-safe | oqs-provider | < 0.6.1 |
Weakness: CWE-120, CWE-130, CWE-190, CWE-680, CWE-805 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
References
- https://github.com/open-quantum-safe/oqs-provider/security/advisories/GHSA-pqvr-5cr8-v6fx x_refsource_CONFIRM
- https://github.com/open-quantum-safe/oqs-provider/pull/416 x_refsource_MISC