Vulnerability · Published Jul 30, 2024 · Assigned by GitHub_M
CVE-2024-37165Discourse has an XSS via Onebox system
Medium 6.3
In plain English
A medium-severity cross-site scripting in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities).
Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.4%top 69.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Discourse is an open source discussion platform. Prior to 3.2.3 and 3.3.0.beta3, improperly sanitized Onebox data could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. This vulnerability is fixed in 3.2.3 and 3.3.0.beta3.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://github.com/discourse/discourse/security/advisories/GHSA-cx83-5p6x-9qh9 x_refsource_CONFIRM
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd x_refsource_MISC
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2 x_refsource_MISC