Vulnerability · Published Jul 12, 2024 · Assigned by apache
CVE-2024-36522Apache Wicket: Remote code execution via XSLT injection
Critical 9.8
In plain English
A critical-severity injection in Apache Wicket from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)2.1%top 18.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.wicket:wicket-util | 10.1.0 | GHSA-hhwc-gh8h-9rrp |
| Maven | org.apache.wicket:wicket-util | 9.18.0 | GHSA-hhwc-gh8h-9rrp |
| Maven | org.apache.wicket:wicket-util | 8.16.0 | GHSA-hhwc-gh8h-9rrp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Wicket | 10.0.0-M1 – through 10.0.09.0.0 – through 9.17.08.0.0 – through 8.15.0 |
Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H