Vulnerability · Published Jun 3, 2024 · Assigned by GitHub_M
CVE-2024-36127apko Exposure of HTTP basic auth credentials in log output
High 7.5
In plain English
A high-severity sensitive data in logs in apko from chainguard-dev. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 61.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
apko is an apk-based OCI image builder. apko exposures HTTP basic auth credentials from repository and keyring URLs in log output. This vulnerability is fixed in v0.14.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | chainguard.dev/apko | 0.14.5 | GHSA-v6mg-7f7p-qmqp |
| Go | chainguard.dev/apko | 0.14.5 | GO-2024-2899 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| chainguard-dev | apko | < 0.14.5 |
Weakness: CWE-522, CWE-532 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N