Vulnerability · Published May 31, 2024 · Assigned by GitHub_M
CVE-2024-36120javascript-deobfuscator crafted payload can lead to code execution
High 8.2
In plain English
A high-severity code injection in javascript-deobfuscator from ben-sb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
javascript-deobfuscator removes common JavaScript obfuscation techniques. In affected versions crafted payloads targeting expression simplification can lead to code execution. This issue has been patched in version 1.1.0. Users are advised to update. Users unable to upgrade should disable the expression simplification feature.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | js-deobfuscator | 1.1.0 | GHSA-9p6p-8v9r-8c9m |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ben-sb | javascript-deobfuscator | < 1.1.0 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H