Vulnerability · Published Jul 3, 2024 · Assigned by GitHub_M
CVE-2024-36113Discourse missing authorization checks for suspending admins/moderators
Medium 4.9
In plain English
A medium-severity missing authorization in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities).
Official description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch, a rogue staff user could suspend other staff users preventing them from logging in to the site. The issue is patched in version 3.2.3 on the `stable` branch, version 3.3.0.beta3 on the `beta` branch, and version 3.3.0.beta4-dev on the `tests-passed` branch. No known workarounds are available.
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
References
- https://github.com/discourse/discourse/security/advisories/GHSA-3w3f-76p7-3c4g x_refsource_CONFIRM
- https://github.com/discourse/discourse/commit/8470546f59b04bd82ce9b711406758fd5439936d x_refsource_MISC
- https://github.com/discourse/discourse/commit/9c4a5f39d3ad351410a1453ff5e5f7ffce17cd7e x_refsource_MISC