Vulnerability · Published Jul 3, 2024 · Assigned by GitHub_M
CVE-2024-35234Discourse vulnerable to stored-dom XSS via Facebook Oneboxes
Medium 4.2
In plain English
A medium-severity cross-site scripting in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities).
Official description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch, an attacker can execute arbitrary JavaScript on users’ browsers by posting a specific URL containing maliciously crafted meta tags. This issue only affects sites with Content Security Polic (CSP) disabled. The problem has been patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch. As a workaround, ensure CSP is enabled on the forum.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:L
References
- https://github.com/discourse/discourse/security/advisories/GHSA-5chg-hm8c-wc58 x_refsource_CONFIRM
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd x_refsource_MISC
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2 x_refsource_MISC