Vulnerability · Published Jun 6, 2024 · Assigned by @huntr_ai
CVE-2024-3504Improper Access Control in lunary-ai/lunary
High 8.1
In plain English
A high-severity incorrect authorization in lunary-ai/lunary from lunary-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Severity (CVSS 3.0)8.1High
Exploit odds (30 days)0.5%top 57.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
An improper access control vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, where an admin can update any organization user to the organization owner. This vulnerability allows the elevated user to delete projects within the organization. The issue is resolved in version 1.2.7.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| lunary-ai | lunary-ai/lunary | unspecified – before 1.2.7 |
Weakness: CWE-863 · Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H